This incident has been resolved and emails are now being delivered normally.
Posted Sep 11, 2025 - 09:46 CDT
Update
We are continuing to work with our email provider and will send an update as soon as email service is fully restored.
Please note that business whose emails are being sent using their own domain are not affected by this issue, and it is only affecting those who send email through the default offeringtree.com email address.
Posted Sep 11, 2025 - 09:01 CDT
Update
We are continuing to work with our email provider and will send an update as soon as email service is fully restored
Posted Sep 11, 2025 - 06:13 CDT
Identified
We are investigating a delay with outbound emails caused by a provider issue. A fix is in progress, and all queued emails will be sent once resolved. We will update you shortly.