Google Cloud Platform Degraded Performance

Incident Report for OfferingTree

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:26 CDT

Monitoring

Google has rolled out a fix for the underlying Cloud Platform issue. We're observing positive signs that OfferingTree sites are loading correctly again. We'll keep a close eye on performance to confirm full resolution.
Posted Jun 12, 2025 - 16:04 CDT

Identified

We're currently experiencing an issue with OfferingTree sites due to a problem with Google Cloud Platform, which stores our files. This may cause sites to not fully load and require a refresh. Google is actively working on a fix, and we'll update you as soon as it's resolved.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW#RP1d9aZLNFZEJmTBk8e1
Posted Jun 12, 2025 - 15:16 CDT
This incident affected: Custom Domain Sites, Sub-domain Sites, and File Storage Service.